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The Jasperactive Teacher’s Guide
The Jasperactive Teacher’s Guide contains all the information you need to teach courses using the
Jasperactive Learning Management System. This guide is designed for use by teachers; however, it is
also advantageous to take a Jasperactive course as a student to familiarize yourself with the student
experience.
For a comprehensive look at how to take a Jasperactive course from a student’s perspective, refer to the
Jasperactive Student User Guide available on the Jasperactive Support web page
(http://support.jasperactive.com).

Using the Jasperactive Teacher’s Guide
The topics in this guide are presented in the same order that their corresponding options appear in the
Teacher Panel (see the Understanding the Teacher Panel section).
However, if you are new to using Jasperactive, you may find it helpful to view the topics in the following
order:
1.
2.
3.
4.
5.
6.
7.
8.

Creating Your Teacher Account
Logging in as a Teacher
Using the Jasperactive Installer
Understanding the Teacher Panel
Downloading the Teacher Resources
Using the Groups Manager
Using the Activity Manager
Using Reports

Creating Your Teacher Account
Everything you do in Jasperactive revolves around your user account.
You can create your Jasperactive teacher account when you receive a Teacher Code from your center
(school) administrator. The Teacher Code you receive associates your teacher account with your center
(school).
If you have not received your Teacher Code, contact your center (school) administrator.
To create your teacher account, perform these steps.
Step 1:

Open your browser and navigate to the Jasperactive home page at
http://www.jasperactive.com.
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The log in area appears at the top of the home page.

Use the log in area to create a new account or log in to an existing account.
Step 2:

In the New User section, click in the Enter activation code field, enter the Teacher Code that
was provided to you, then click the Activate button.
The Registration – Connect Your Account page appears, giving you the option to automatically
populate some of the fields in the registration form with information from one of your social
media accounts.

Step 3:

If you want to automatically populate some of the fields in the registration form, click the icon
for the social media account you want to use; otherwise, click Skip.
An empty registration form appears.

Step 4:
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Complete the form as appropriate, then click Submit.
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The Jasperactive End-User License Agreement appears.

Step 5:

Please read the Jasperactive End-User License Agreement carefully, then click Accept.
The center (school) associated with your Teacher Code appears.

Step 6:

Click Confirm to link your teacher account to your center (school).
The Teacher Panel (your personal Jasperactive home page) appears.
Your account has been successfully created. The next time you want to access Jasperactive,
you will enter your email address and password in the Registered User section.

Understanding Jasperactive Accounts and Roles
Each Jasperactive user account has one or more roles associated with it. The roles associated with your
user account determine what you can and cannot do within Jasperactive.
All account types (except for student accounts) can access the drop-down Role menu, which displays in
the navigation bar below your name when you log in. An expanded Role drop-down menu is shown
here.
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You can select (and work from the perspective of) any role that appears in the drop-down menu. Not all
users have the same options available. For example, your choices may be limited to Teacher and
Student, or Center Admin and Student, and so on.

Logging in as a Teacher
To log in to your Jasperactive teacher account, perform these steps.
Step 1:

Open your browser and navigate to the Jasperactive home page at
http://www.jasperactive.com.

Step 2:

In the Registered User section, click in the Email field and enter the email address associated
with your Jasperactive teacher account.

Step 3:

Click in the Password field and enter your password.

Step 4:

Press ENTER or click the Log In button to access your personal Jasperactive home page.

Step 5:

Click the arrow below your name to display the Role drop-down menu.

Step 6:

In the Role drop-down menu, select Teacher if necessary to display the Teacher Panel.
If you do not have a teacher account, please contact the Center administrator for your school
to obtain a teacher account.
For information about accounts and roles, refer to the Understanding Jasperactive Accounts
and Roles guide available at http://support.jasperactive.com/.

Understanding the Teacher Panel
When you log in to Jasperactive as a Teacher, the Teacher Panel appears.
The Teacher Panel contains the tools and resources necessary to teach courses using Jasperactive.
Using the options available in the Teacher Panel, you can set up and manage groups (classes), create and
manage custom activities, track student progress, access teacher resources, and ensure you are using
the latest version of Jasperactive.

4
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The navigation bar on the Teacher Panel home page contains icons that mimic the options available in
the Teacher Panel. You can use the icons to quickly switch between tasks and return to the home page
from anywhere in the system.

The navigation bar includes the following icons:
Home Page

Click to return to the Teacher Panel home page.

Activity Manager

Click to access the Activity Manager page, from which you can
create and assign custom exercises or quizzes.

Groups Manager

Click to access the Groups Manager page, from which you can
create and manage groups, assign specific courses, adjust
rubrics/times, reset passwords, and so on.

Reports

Click to access the Reports page, from which you can track student
progress and gather course completion information.

Teacher Resources

Click to access the Download Teacher Resources page, from which
you can download individual course components or a full resource
kit.

Jasperactive Installer

Click to access the Jasperactive Installer page, from which you can
install Jasperactive, check for updates, and review the changes
provided in the current release of Jasperactive.
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Using the Activity Manager
In Jasperactive, assessments, lesson quizzes, and lesson exercises are called activities. Hundreds of
activities are built in to Jasperactive; these are called system activities. Jasperactive also allows you, as a
teacher, to create your own supplemental activities; these are called custom activities. Custom activities
are shared with all registered Jasperactive teachers at your center (school).
You can use the Activity Manager to view and manage the activities in your courses. You can view the
tasks being checked (graded) by Jasperactive in a system activity, but you cannot edit or delete system
activities.

Searching for an Activity
This section explains how to search for an activity.
To search for an activity, perform these steps.
Step 1:

In the Teacher Panel, click the Activity Manager option.
The Activity Manager page appears.

You can use the fields in the Search Activities section to filter your search results. You can
filter by activity name, application, activity type, and author.
Step 2:

In the Search Activities section, enter the activity name. If you do not know the name, or if
you want to see all the activities that meet the other filtering criteria, leave this field blank.

Step 3:

In the Application drop-down menu, select the application for which you want to see the
available activities. For example, if you select Access 2016, then the search results table will
display all activities in the Jasperactive Access 2016 course.

Step 4:

In the Activity Type drop-down menu, select the type of activity for which to search. The
choices include Benchmark, Quiz, Learn, Create, Validate, Custom Exercise, and Custom Quiz.
If you choose to search for a Custom Exercise or Custom Quiz, the Author drop-down
menu is activated. Select All Custom Activities to search for all shared custom activities, or
select My Custom Activities to search only for those activities you created.

6
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Step 5:

Click Search to display a list of the activities that meet your specifications. The activities
appear in the search results table.

System activities (authored by Jasperactive) are available for viewing purposes only. Click the
magnifying glass ( ) icon in the Options column to view the activity.
Custom activities (authored by you or a coworker) may be viewed, edited, or deleted. Click
the pencil ( ) icon to edit the activity. Click the delete (X) icon to delete the activity.
You can view custom activities created by anyone at your center (school) but you can edit or
delete only your own custom activities.

Understanding Exercise Elements
This section introduces and explains Jasperactive exercise elements.
Before you begin working in the Activity Manager, it is important to familiarize yourself with the
elements that make up a Jasperactive exercise.
Each exercise consists of the following elements:
•
•
•
•
•

An exercise name

Instructions for completion
Exercise tasks

Task steps (instructions)

A starter file that is opened automatically or available to be opened by the student at the
start of the exercise

© 2018 Jasper Learning Inc. – All rights reserved.
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•

Optional supplemental (resource) files, such as images and text files, that the student will use
during the exercise

Several of these elements are shown in the following image.

For grading purposes, each exercise task has associated with it graded items called parameters.
Each parameter includes the following associated values:
•
•

A validation (or grading) value, called a Value to Compare

Where applicable, a value that indicates the text that will be displayed in the instruction pane,
called a Value to Show

In the image below, in the Instructions for the Student section, the words appearing in brackets are
parameters. The Validation Parameters table lists the parameters and the parameters’ associated
values.

8
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In the preceding figure, the parameter named [StartsWith] will display the text indicated in the Value to
Show column in the instruction pane.
When the student sees Step 1, it will read:
Jasperactive will compare the text selected
by the student to the text indicated in the Value to Compare column. If the correct words are selected,
the task will be marked as correct.
Keep these concepts in mind as you work with the Activity Manager.

Viewing Jasperactive’s Validation Parameters
This section explains how to view Jasperactive validation parameters.
The Activity Manager can be used to determine the validation parameters Jasperactive uses when
grading an exercise. This is helpful if a student reports that he or she has completed an exercise task
correctly but the task was marked as incorrect by Jasperactive.
To determine which tasks are being validated by Jasperactive, perform these steps.
Step 1:

In the Teacher Panel, click the Activity Manager option to display the Activity Manager page.

© 2018 Jasper Learning Inc. – All rights reserved.
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Step 2:

In the Application drop-down menu, select the application associated with the exercise you
want to view.

Step 3:

In the Activity Type drop-down menu, select the type of activity for which to search.

Step 4:

Click Search to display a list of the activities that meet your specifications.

Step 5:

Locate the desired activity, and in the Options column, click the magnifying glass (
display the General Information page.

10
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Step 6:

Click the Tasks tab to display the list of exercise tasks.
By default, tasks are displayed in List View (as shown in the image on the left). You can click
the Tree View radio button in the View Type section to display the tasks in a hierarchical
outline list (as shown in the image on the right).

Step 7:

In List View, locate the desired task, and then in the Options column, click the magnifying
glass ( ) icon to display the selected task page.
In Tree View, use the expand ( ) or collapse ( ) icons to locate the desired task, and then
click the task name to display the associated task page.

© 2018 Jasper Learning Inc. – All rights reserved.
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View the Validation Parameters table to determine the validation parameters and the

associated values Jasperactive uses to validate (grade) the exercise task.

To familiarize yourself with the elements that make up a Jasperactive exercise, refer to the
Using the Activity Manager > Understanding Exercise Elements section.
Step 8:

When you have finished reviewing the validation information, click Cancel to return to the
Tasks page.
To view another exercise, click Cancel on the Tasks page to return to the activity search
results list.

You can also determine if an exercise is validating correctly by running a report on the exercise. The
report will show you which students have worked on the exercise and whether any of them were able to
complete the tasks successfully. Refer to the Using Reports > Viewing Reports in Export View >
Generating an Exercise Result Report for Lesson Exercises section for information about how to run a
report on an exercise.
Any student successfully completing the exercise indicates that Jasperactive is validating the exercise
correctly. Students who received an incorrect mark have performed a task or step incorrectly.

Creating a Custom Exercise
This section explains how to create a custom exercise in Jasperactive.
You can use the Activity Manager to create custom exercises from the existing exercise content available
in Jasperactive.
To familiarize yourself with the elements that make up a Jasperactive exercise, refer to the Using the
Activity Manager > Understanding Exercise Elements section.

12
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When creating a custom exercise, you must insert portions of existing exercise content for validation
(grading) purposes. Although you cannot create new parameters (graded elements), you can modify the
value of an existing parameter (the answer Jasperactive is looking for) to suit your needs. For instance, if
the [WordArtType] parameter value is Gradient Fill, Blue, you can modify the value to check for a
different WordArt type, such as Fill:Gold, Accent color 4.
Additionally, all course starter and resource files are available for your use.
Before beginning the creation process, we recommend that you determine which exercises, tasks, and
data files you want to include in the exercise. You may also find it helpful to consult the course Data
Map included with the Teacher Resources.
Creating a custom exercise can be broken down into two distinct steps: setting up the custom exercise
and adding tasks to the custom exercise.

Setting Up the Custom Exercise
When setting up a custom exercise, you are required to specify:
•
•
•
•

an exercise name.

the application to be used.

the activity type.

the instructions necessary to complete the exercise.

You may also decide to include the following:
•
•
•

A description of the exercise
A time limit for completion

Data files to be used while performing the exercise tasks

To set up a new custom exercise, perform these steps.
Step 1:

In the Teacher Panel, click the Activity Manager option to display the Activity Manager page.

Step 2:

Click the Add New Activity button to create a new activity. The General Information page
appears.

© 2018 Jasper Learning Inc. – All rights reserved.
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Step 3:

In the Activity Name field, enter the exercise name.

Step 4:

In the Application drop-down menu, select the application you would like to associate with
the exercise.

Step 5:

Verify the Activity Type is set to Custom Exercise.

Step 6:

Enter a description of the exercise.

Step 7:

Enter a time limit, if applicable, to complete the exercise.

You can use the Language drop-down menu to specify the language, English or Spanish.
Step 8:

14

In the Instructions tab, enter instructions for completing the exercise. The instructions will
appear in the student instruction pane, as shown below.
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You can use the menus and toolbars to customize the instruction content. To preview the
content, select Preview in the View menu.
Step 9:

Click the Starter Files tab to display the list of Starter Files you can use for the exercise.
Starter Files are the files that are opened automatically or are made available to the student
to open at the beginning of the exercise.

Step 10: Select the check box(es) to the left of the data file(s) you want to use at the start of the

exercise. To preview the file contents, click the magnifying glass (

) icon in the View column.

To have the file open automatically when the exercise loads, click the check box in the Auto
Open column. An exercise may include up to ten files (starter and resource).
Keep in mind that you must keep track of the order in which the files are opened. Jasperactive
refers to the files by number; the first file to be opened is document 1, the second file to be
opened is document 2, and so on.
Step 11: If the exercise will include supplemental files that the student will use during the exercise,

click the Resources tab. Resource files can include text files, graphics, and other file types.

© 2018 Jasper Learning Inc. – All rights reserved.
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Step 12: Select the check box(es) to the left of the data file(s) you want to be made available during

the exercise.

To preview the file contents, click the magnifying glass (

) icon in the View column.

Step 13: Click Save when you have completed the preliminary setup. A notification bar appears at the

top of the window indicating the exercise data has been saved. Notice that the Tasks tab
appears to the right of the General Information tab.

You can click Cancel to cancel the changes and return to the Activity Manager home page.

Adding Tasks to the Custom Exercise
After you have completed setting up the custom exercise, you are ready to add exercise tasks.
This section explains how to choose and modify existing exercise tasks to include in the custom exercise.
Step 1:

Click the Tasks tab to display the Tasks page.

Step 2:

Click the Add New Task button to display the Add New Task window.

16
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Step 3:

Verify the appropriate question (task) number appears in the Question Number field.
Jasperactive automatically numbers the questions (tasks). To change the order of the
questions, change the entry in the Question Number field.

Step 4:

If necessary, select the appropriate document number in the Apply to document number
drop-down menu.
Use the Apply to document number drop-down menu to indicate which document
Jasperactive should evaluate for the tasks students will perform.

Step 5:

On the left side of the window, click the Lesson drop-down menu to select a lesson. The
available topics appear below the selected lesson.

Step 6:

Click the expand ( ) or collapse ( ) icons to the left of the topics to display the available
exercises.

Step 7:

Select an exercise to display the associated tasks in the Select a Task box.

Step 8:

Select a task in the Select a Task box to display the task instructions. The task instructions
(steps) appear in the Instructions for the Student box on the right.

© 2018 Jasper Learning Inc. – All rights reserved.
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Working with Parameters
In the Instructions for the Student box, text that appears within square brackets, such as
[StartsWith], are called parameters. Parameters are used for grading purposes. Not all tasks
include parameters.
If the selected task includes graded items (parameters), the Validation Parameters table
appears. The Validation Parameters table lists the task parameters and their associated values
in alphabetical order.
You can change parameter values in the Value to Compare and Value to Show columns in the
Validation Parameters table:
• Value to Compare – indicates the information Jasperactive is validating (grading).
• Value to Show – indicates the text that will be displayed in the instruction pane.
To familiarize yourself with the elements that make up a Jasperactive exercise, refer to the
Using the Activity Manager > Understanding Exercise Elements section.
Step 9:

Modify the instructions that appear in the Instructions for the Student section, as needed.
Please note the instruction steps are presented in a table. Use the Table drop-down menu to
add or delete rows and columns. You can use the menus and toolbars to format the
instruction content.

Step 10: After you have completed the information in the Add New Task window, click Save. A

notification bar appears at the top of the window indicating the exercise data has been saved.

Step 11: Click Add New Task to add additional tasks to the exercise, as applicable.

Remember to keep track of the question (task) number and the Apply to document number
as you add new tasks to the exercise.
Click Save and repeat the process until the exercise is complete.

18
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Notice that, as you add new tasks, Jasperactive remembers from which lesson you are
drawing the topics for this exercise.
As you save tasks to the exercise, they will be added to the Tasks list on the Tasks page.

Jasperactive lists the tasks in the order they will appear when the exercise is assigned to
students within the Jasperactive course.
To edit a task or adjust the task order, click the pencil ( ) icon in the Options column.
To delete a task, click the delete (X) icon in the Options column.
Step 12: When you have finished adding tasks to the exercise, click Cancel to return to the main
Activity Manager page.

After you create custom exercises, you can use the Groups Manager option in the Teacher Panel to
assign the custom exercises to a group, and to delete the custom exercises from a group. Refer to the
Using the Groups Manager > Assigning a Custom Activity and Using the Groups Manager > Deleting an
Assigned Custom Activity sections.

Creating a Custom Quiz
This section explains how to create a custom quiz.
You can use the Activity Manager to create custom quizzes.
Creating a custom quiz can be broken down into three distinct steps: setting up the quiz, adding
questions to the quiz, and adding answers to the quiz questions.

Setting Up the Custom Quiz
When setting up a custom quiz, you are required to specify:
•
•

a quiz name.

the application to be used.

© 2018 Jasper Learning Inc. – All rights reserved.
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•
•

the activity type.

instructions for the student.

You may also decide to include the following:
•
•

A description of the quiz

A time limit for completion

Although a description is optional, it is important to note that only the description (not the instructions)
will be visible to students when they view the custom quiz that has been assigned to them. It is highly
recommended that you enter a description which provides basic instructions to the students. For
example, you might enter the text Select the best answer to each question as a quiz description.
To set up a new custom quiz, perform these steps.
Step 1:

In the Teacher Panel, click the Activity Manager option to display the Activity Manager page.

Step 2:

Click the Add New Activity button to create a new activity. The General Information page
appears.

20
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Step 3:

In the Activity Name field, enter the quiz name.

Step 4:

In the Application drop-down menu, select the application you would like to associate with
the quiz.

Step 5:

In the Activity Type drop-down menu, select Custom Quiz.

Step 6:

In the Description field, enter instructions for the student. The text you enter in this field will
be displayed in the Description field in the My Tasks window as shown in the following figure.

Step 7:

Enter a time limit, if applicable, to complete the quiz.

© 2018 Jasper Learning Inc. – All rights reserved.
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You can use the Language drop-down menu to specify the language, English or Spanish.
Step 8:

In the Instructions tab, enter a few characters of text. The text you enter here will not be
visible to students; however, an entry is required in order to save the quiz.

Step 9:

Click Save when you have completed the preliminary setup. A notification bar appears at the
top of the window indicating the quiz data has been saved. Notice that the Questions tab
appears to the right of the General Information tab.

You can click Cancel to return to the Activity Manager home page. All saved data is
retained by Jasperactive.

Adding Questions to the Custom Quiz
After you have completed setting up the custom quiz, you are ready to add quiz questions.
This section explains how to add questions to the custom quiz, edit questions, and adjust the order in
which the questions appear.
If you exited the quiz, perform the steps in the Using the Activity Manager > Searching for an Activity
section to reopen the custom quiz.
To add questions to the custom quiz, perform these steps.
Step 1:

22

Click the Questions tab to display the Questions page.
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Step 2:

Click the Add New Question button to display the Add New Question window.

Step 3:

Click the Lesson drop-down menu and select a lesson. After you a select a lesson, the
available topics will appear in the left side of the window.

Step 4:

Click the expand ( ) or collapse ( ) icons to the left of the topics to display the available
subtopics.

Step 5:

Click the desired subtopic to select it.

© 2018 Jasper Learning Inc. – All rights reserved.
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It is important to specify the subtopic so that Jasperactive can provide remediation and
properly point students to where the information can be found.
The Add New Question window title updates to include the subtopic you selected.
Step 6:

Verify the appropriate question number appears in the Question Number field.
Jasperactive automatically numbers the questions. To change the order of the questions,
change the entry in the Question Number field.

Step 7:

Click in the text box below the Question Number field and enter the question stem.

If you have question text stored in another file, you can copy and paste the text from that
document into Jasperactive.
Step 8:

Click Save to save the question. A notification bar appears at the top of the window indicating
the quiz question has been saved and the question appears in the Questions table.

Alternatively, you can click Cancel to return to the Activity Manager home page.

24
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You may add answers to the quiz question now or continue adding questions and add the
answers later. To add answers, refer to the Using the Activity Manager > Creating a Custom
Quiz > Adding Answers to the Quiz Questions section.
Step 9:

To add another question to the quiz, click Add New Question and repeat Steps 3 - 8.

As you save questions to the quiz, the question list updates. The Questions page lists the
questions in the order they will appear.
You can click Cancel to return to the Activity Manager home page. All saved data is
retained by Jasperactive.

Editing a Question
To edit a question or adjust the question order, perform these steps.
If you exited the quiz, follow the steps in the Using the Activity Manager > Searching for an Activity
section to reopen the custom quiz. Then click the Questions tab to open the Questions page.
Step 1:

In the Questions table, locate the row for the question you want to edit, and in the Options
column, click the pencil ( ) icon. The question detail section appears below the Questions
table.

© 2018 Jasper Learning Inc. – All rights reserved.
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Step 2:

Edit the question information as needed, and then click Save. A notification bar appears at
the top of the window indicating the changes have been saved.
To delete a question, click the delete (X) icon in the Options column or click the Delete button
in the question detail section. A message window appears asking you to confirm that you
want to proceed. Click OK to delete the question. A notification bar appears at the top of the
window indicating the changes have been saved, and the Questions table updates to reflect
the change.

Adding Answers to the Quiz Questions
After you have added questions to the custom quiz, you are ready to add answers to the questions.
This section explains how to add answers to quiz questions.
If you exited the quiz, follow the steps in the Using the Activity Manager > Searching for an Activity
section to open the custom quiz. Then click the Questions tab to open the Questions page.
Step 1:
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In the Questions table, locate the row for the question to which you want to add answers, and
in the Options column, click the pencil ( ) icon. The Questions page displays the question
detail section for the selected question.
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You will use the Add New Answer button to enter all answers for the question. The answers
include the correct answer and the distractors (incorrect answer options). The answers will
appear in random order during the quiz.
Step 2:

Click the Add New Answer button to display the Add new answer to question window.

Step 3:

In the Answer field, enter the correct answer for the question.
By default, the first answer provided is designated as the correct answer.

Step 4:

Click Save to save the answer. A notification bar appears at the top of the window indicating
the question answer has been saved and the answer appears in the Answer table.
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Alternatively, you can click Cancel to return to the Activity Manager home page.

To edit an answer, click in the Answer field, edit the answer as needed, and then click Save in
the question detail section.
To deactivate an answer, deselect the check box in the Active column, and then click Save in
the question detail section. When you deactivate an answer, it will not be visible to students
when they view the custom quiz.
To delete an answer, click the delete (X) icon to the right of the answer. A message window
appears asking you to confirm that you want to proceed. Click OK to confirm the deletion. The
Answer table updates to reflect the change.
Step 5:

To add an explanation to help students understand the correct answer, enter the explanatory
text in the Supplementary Answer field. The supplementary answer is visible to students
when they review the quiz questions they answered incorrectly.

Step 6:

To add another answer to the question, click Add New Answer and repeat steps 2 – 4.
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When you have finished entering the question answers, the answer section will appear similar
to the following figure.

To designate a different answer as the correct answer, click the check box in the Correct
column to select it. A message window appears asking you to confirm that you want to
proceed. Click OK to confirm you want to mark the answer as correct. A notification bar
appears at the top of the window indicating the change was saved. The Answer table updates
to reflect the change.
Step 7:
Step 8:

When you have finished adding answers to the question, click Cancel to return to the main

Activity Manager page.
Click the Home Page (

) icon in the navigation bar to return to the Teacher Panel page.

After you create custom quizzes, you can use the Groups Manager option in the Teacher Panel to assign
the custom quizzes to a group, and to delete the custom quizzes from a group. Refer to the Using the
Groups Manager > Assigning a Custom Activity and Using the Groups Manager > Deleting an Assigned
Custom Activity sections.

Deactivating a Custom Activity
This section explains how to deactivate a custom activity.
You can use the Activity Manager to deactivate custom exercises and quizzes that you have authored. A
custom activity that has been deactivated can still be assigned to students, but students will be unable
to see (or perform) the assigned activity until it has been reactivated.
To deactivate a custom activity, perform these steps.
Step 1:

In the Teacher Panel, click the Activity Manager option.
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Step 2:

Enter the activity name. If you do not know the name, leave this field blank to display a list of
all activities associated with the chosen application and activity type.

Step 3:

In the Application drop-down menu, select the application associated with the activity.

Step 4:

In the Activity Type drop-down menu, select the type of activity for which to search.

Step 5:

In the Author drop-down menu, select My Custom Activities.

Step 6:

Click Search to display a list of the custom activities you specified.

Step 7:

In the search results table, locate the row for the activity you want to deactivate, and in the
Options column, click the pencil ( ) icon to display the General Information page.

Step 8:

Click the Active Activity check box to deselect it. Deselecting this check box will deactivate the
activity.
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Step 9:

Click Save. A notification bar appears at the top of the window indicating the changes have
been saved.

To view the change, you must refresh the search results table.
Step 10: Click the Activity Manager (

home page.

) icon in the navigation bar to return to the Activity Manager

Step 11: Re-enter the activity’s search information, and then click Search.

Notice that, in the Active column of the search results table, the check box for the specified
activity is deselected, indicating that the activity is now inactive.

If you want to reactivate an inactive activity, navigate to the General Information tab for the
activity you want to reactivate. Click the Active Activity check box to select it, and then click
Save. Refresh the search results table to confirm that the activity is now active.

Deleting a Custom Activity
This section explains how to delete a custom activity.
You can use the Activity Manager to delete custom exercises and quizzes that you authored.
To delete a custom activity, perform these steps.
Step 1:

In the Teacher Panel, click the Activity Manager option.

© 2018 Jasper Learning Inc. – All rights reserved.

31

Jasperactive Teacher’s Guide
v1.0

Step 2:

Enter the activity name. If you do not know the name, leave this field blank to display a list of
all activities associated with the chosen application and activity type.

Step 3:

In the Application drop-down menu, select the application associated with the activity.

Step 4:

In the Activity Type drop-down menu, select the type of activity for which to search.

Step 5:

In the Author drop-down menu, select My Custom Activities.

Step 6:

Click Search to display a list of the custom activities you specified.

Step 7:

In the search results table, locate the row for the activity you want to delete, and in the
Options column, click the delete (X) icon. A message window appears asking you to confirm
that you want to proceed. Click OK to confirm the deletion. A notification bar appears at the
top of the window and the search results table updates to reflect the deletion of the custom
activity.

Using the Groups Manager
The Groups Manager serves as a central location for managing courses, individual students, student
groups (classes), grading rubrics, and assignments.
You can use the Groups Manager to:
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•
•
•
•
•
•
•
•

create student groups.

manage groups.

modify the available course list and course duration.

view and edit student information.

reset the Benchmark assessment.

assign and delete custom exercises and quizzes.

adjust the grading rubrics for individual students and groups.

modify assessment time limits.

Creating a Group
In Jasperactive, a group is made up of students (or users) linked to a specific class/teacher. Group
members are assigned a group key that associates their account with a center (school), license, teacher,
and course(s).
To enable reporting, groups should be created regardless of the type of license (Center or User
Activation Codes) purchased by your organization.
This section explains how to create a group.
To create a new group, perform these steps.
Step 1:

In the Teacher Panel, click the Groups Manager option.
The Groups Manager page appears.

Step 2:

Click the Add New Group button. The New Group window opens and displays the General
Information tab.
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Step 3:

Use the fields in the General Information tab to enter information for the new group.
The fields are described in the following table.
Group Key

A unique group key will be generated and will appear in this field after
the new group has been created.

Group Name

Enter a descriptive name for your group (for example, BusApps P2 Sem1
1718).

Current Licenses

The number and type of licenses your organization has purchased will
appear in the Current Licenses drop-down menu.

Select the license you have been authorized to use for your group(s).
If you select a Center License, you will need to enter a start date and
finish date in the associated fields.

Your group key will act as an activation code for new users and will
automatically link students to your group. Students who already have a
Jasperactive account can use the code to link to your group.
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For information about where and when to enter a Center licensegenerated group key, refer to the Using the Groups Manager > Creating a
Group > Distributing Group Keys section.
If you select a User Activation Codes license, then the group key will
allow students to link to your group, but students will still need a
separate activation code to create and activate a Jasperactive account.
Please ensure you have been given the student User Activation Codes
for your location so that you can distribute these to your students along
with your group key. If you have not received the codes, please contact
your system administrator.
For information about where and when to enter a User Activation Codes
License-generated group key, refer to the Using the Groups Manager >
Creating a Group > Distributing Group Keys section.
After you have selected a license from the Current Licenses drop-down menu, the
Jasperactive courses that have been purchased for your location appear. Each suite of courses
displays in its own tab.
If you are using a User Activation Codes license, the courses are pre-selected and you can skip
to Step 6.
Step 4:

If you are using a Center license, you may select the courses you want to make available to
your group. Click an application suite tab and select the desired courses.

Step 5:

Click Save to create the group and generate the group key.

Step 6:

Distribute the Group Key to each student on your class roster, and provide instructions about
where to enter the key. Refer to the Distributing Group Keys section for details.

Step 7:

Click Cancel to return to the Groups Manager page.
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Step 8:

To verify the creation of the new group (and to list all groups associated with your teacher
account), clear all criteria in the Search Groups section, and then click Search.

To view or edit a group’s information, locate the row for the group you want to access, and in
the Options column, click the pencil ( ) icon.
To delete a group, locate the row for the group you want to delete, and in the Options
column, click the delete (X) icon.

Distributing Group Keys
A group key associates a student account with a school, a license, a teacher, and one or more courses. A
student can use a group key to create an account, activate a course, link to a teacher, or change the
license associated with a course.
As a teacher, you can generate a group key from a User Activation Codes license, or from a Center
license.
A group key that is generated from a User Activation Codes license is used to link an existing student
account to your group. If you are distributing a User Activation Codes-generated group key, instruct
students to go to the course home page, then click the Link to a teacher ( ) icon in the course
navigation bar to open the Teacher window. Students should enter the group key code in the Group Key
field, click Search to find the group and teacher, and then click Link to this Group.
For information about linking to a group, refer to the Linking to a Teacher guide available at
http://support.jasperactive.com/.
A group key that is generated from a Center license can be used to:
•
•
•

create a new student account.

activate a new course.

link a student account to a group (and the courses associated with the group).

The Center license-generated group key should be entered in one of three specific locations, depending
upon the situation, as described in the following table.
If the key will be
distributed to …

Enter the group key in the …

students who have not yet
created their Jasperactive
student accounts

Enter activation code field in the Enter the group key code in the
New User section on the
field, then click the Activate button
Jasperactive home page
to create a new Jasperactive
student account and associate the
new course(s) with the student
account.
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students with active
accounts who have not yet
activated the course(s) for
which you have generated
the key

ACTIVATION CODE field in the
Your Courses section

In the Your Courses section on your
personal Jasperactive home page,
click the Activate a New Course link
to access the ACTIVATION CODE
field.
Enter the group key code, click
Activate Course, then click Confirm
to associate the new course(s) with
the student account.

students who have
previously activated the
course (for example, with
another teacher) for which
you have generated the key
OR
students whose courses
have expired

Group Key field in the Teacher
window

Go to the course home page, then
in the course navigation bar, click
the Link to a teacher (
) icon to
open the Teacher window.
Enter the group key code, click
Search, and then click Link to this
Group to associate the course with
the new group and apply the
license to the course.

If a student tries to use a group key code to activate a course that he or she has already activated, the
student will receive an error message resembling the one shown here.

Because the student has already activated the course, he or she must link to your group. Refer to the
third scenario outlined in the preceding table.
For information about creating a new Jasperactive student account, refer to the Activating a Brand New
Account guide available at http://support.jasperactive.com/.
For information about activating a new course, refer to the Viewing Your Courses guide available at
http://support.jasperactive.com/.
For information about applying a new license to a course, refer to the Linking to a Teacher guide
available at http://support.jasperactive.com/.

Managing Groups
This section explains how to find a group, edit group information, add and remove students in a group,
deactivate a group, and delete a group.
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Finding a Group
You can use the Groups Manager to find groups associated with your teacher account.
Step 1:

In the Teacher Panel, click the Groups Manager option.
The Groups Manager page appears.

Step 2:

If you know the group name or key, click in the Group Name or Key field to enter a group
name. You can also select specific courses by clicking the appropriate check boxes.
You can perform a search without entering any criteria if you want to see all the groups
associated with your teacher account.

Step 3:
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Editing Group Information
You can change options for a group (such as the group name, description, start and finish dates, and
available courses) after the group has been created.
Step 1:

Click the Groups Manager option in the Teacher Panel, and use the search feature to find the
groups associated with your teacher account.

Step 2:

In the search results table, locate the row for the group you want to edit, and in the Options
column, click the pencil ( ) icon. The General Information, Group Students, Assessment
Rubrics and Activities, and Customize Time tabs appear in the Groups Manager page.
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Step 3:

Use the editable fields in the General Information tab to adjust the group name, description,
dates, or available courses. (You cannot alter the group key or the license used by the group.)

Step 4:

Click Save. A notification bar appears at the top of the window indicating the changes were
saved.

Adding Students to a Group
You can use the Group Students tab in the Groups Manager page to add a user who created his or her
student account with a User Activation Code (instead of a Center license) to your group.
To add students to a group, perform these steps.
Step 1:

Click the Groups Manager option in the Teacher Panel, and use the search feature to find the
groups associated with your teacher account.

Step 2:

In the search results table, locate the row for the group to which you want to add students,
and in the Options column, click the pencil ( ) icon. The General Information, Group
Students, Assessment Rubrics and Activities, and Customize Time tabs appear in the Groups
Manager page.

Step 3:

Click the Group Students tab and select a course in the Show students enrolled in drop-down
menu. The search results table shows the students currently enrolled in that class.
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Step 4:

Click the Add Students to Group button. The Add students to group (group name) window
appears.

Use the fields in the Search Students section to search for a user who is already registered as
a student.
Step 5:

Select or type entries into the fields, then click Search Students to display the results.
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Step 6:

In the search results table, in the Add column, select the check box for each student you want
to add to the group. (If a check box is unavailable, the student already belongs to one of your
groups, or the student is linked to another group for this course.)

Step 7:

Click Add Students. A notification bar appears at the top of the window and the search results
table updates, indicating the selected student(s) was successfully added.

Step 8:

Click Cancel to return to the Groups Manager page.

Removing Students from a Group
You can use the Group Students tab in the Groups Manager page to remove students from a group.
Step 1:

Click the Groups Manager option in the Teacher Panel, and use the search feature to find the
groups associated with your teacher account.

Step 2:

In the search results table, locate the row for the group from which you want to remove
students, and in the Options column, click the pencil ( ) icon. The General Information,
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Group Students, Assessment Rubrics and Activities, and Customize Time tabs appear in the
Groups Manager page.
Step 3:

Click the Group Students tab and select a course in the Show students enrolled in drop-down
menu.

Step 4:

In the search results table, locate the row for the student you want to remove from the
group, and in the Options column, click the delete (X) icon. A message window appears asking
you to confirm that you want to proceed.

Step 5:

Click OK. A notification bar appears at the top of the window and the search results table
updates, indicating the student was successfully removed from the group.

Step 6:

Click Cancel to return to the Groups Manager page.

Making a Group Inactive
You can use the General Information tab in the Groups Manager page to make a group inactive.
Step 1:

Click the Groups Manager option in the Teacher Panel, and use the search feature to find
the groups associated with your teacher account.

Step 2:

In the search results table, locate the row for the group that you want to make inactive, and
in the Options column, click the pencil ( ) icon. The General Information, Group Students,
Assessment Rubrics and Activities, and Customize Time tabs appear in the Groups Manager
page.

Step 3:

In the General Information tab, deselect the Active Group check box.

Step 4:

Click Save. A notification bar appears at the top of the window, indicating the changes were
saved.
If you want to find an inactive group to reactivate it, be sure to deselect the Show only active
groups check box in the Search Groups section of the Groups Manager page.

Step 5:

Click Cancel to return to the Groups Manager page.

Deleting a Group
You can use the search feature in the Groups Manager page to delete a group.
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Step 1:

Click the Groups Manager option in the Teacher Panel, and use the search feature to find the
groups associated with your teacher account.

Step 2:

In the search results table, locate the row for the group that you want to delete, and in the
Options column, click the delete (X) icon. A message window appears asking you to confirm
that you want to proceed.

Step 3:

Click OK to delete the group permanently. A notification bar appears at the top of the
window, indicating the changes were saved.

Modifying the Available Course List
This section explains how to use the Groups Manager to modify the courses that are available to
students enrolled in your groups.
To modify the courses that are available to students in a group, perform these steps.
Step 1:

Click the Groups Manager option in the Teacher Panel, and use the search feature to find the
groups associated with your teacher account.

For instructions about using the search feature, refer to the Using the Groups Manager >
Managing Groups > Finding a Group section.
Step 2:
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© 2018 Jasper Learning Inc. – All rights reserved.

Jasperactive Teacher’s Guide
v1.0

The available courses display in the lower portion of the General Information tab. Application
suites display on separate tabs. Courses for which the check box is currently selected are
available to students in the group.
Step 3:

Click the appropriate tab, if necessary, then select or deselect the course check boxes to
adjust which courses will be available to students in the group.

Step 4:

Click Save. A notification bar appears at the top of the window, indicating the changes were
saved.

Viewing and Editing Student Information
This section explains how to view and edit information for a student from within the Groups Manager.
First, you must find the group to which the student is linked, then you can find the student in the Group
Students tab.
To view and edit information for a student, perform these steps.
Step 1:

Click the Groups Manager option in the Teacher Panel, and use the search feature to find the
groups associated with your teacher account.
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For instructions about using the search feature, refer to the Using the Groups Manager >
Managing Groups > Finding a Group section.
Step 2:

In the search results table, locate the row for the group you want to examine, and in the
Options column, click the pencil ( ) icon. The General Information, Group Students,
Assessment Rubrics and Activities, and Customize Time tabs appear in the Groups Manager
page.

Step 3:

Click the Group Students tab and select a course in the Show students enrolled in drop-down
menu to display the list of students enrolled in that class.

The Options column displays icons for viewing or editing student information:

Click this to set or reset the student's user name or password.
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Click this to customize the rubrics set for the student. Click in the Value field for the
item you want to edit. Values must total 100%.

You can also click the Assign Activity button in the Rubrics window to assign a
custom exercise or quiz to the student. (For more information, refer to the Using the
Groups Manager > Assigning a Custom Activity section.)
Click this to customize the time allocated to complete the Benchmark and/or Validate
assessments. This option changes the allocated time for this student only.

Click this to view student information and overall course progress percentages.
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Click this to remove the student from the group permanently.

Resetting Passwords
This section explains how to reset a password for a student from within the Groups Manager. First, you
must find the group to which the student is linked, then you can find the student in the Group Students
tab.
To reset a student's password, perform these steps.
Step 1:

Click the Groups Manager option in the Teacher Panel, and use the search feature to find the
groups associated with your teacher account.

For instructions about using the search feature, refer to the Using the Groups Manager >
Managing Groups > Finding a Group section.
Step 2:

In the search results table, locate the row for the group you want to examine, and in the
Options column, click the pencil ( ) icon. The General Information, Group Students,
Assessment Rubrics and Activities, and Customize Time tabs appear in the Groups Manager
page.

Step 3:

Click the Group Students tab, and select a course in the Show students enrolled in drop-down
menu to display the list of students enrolled in that class.
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Step 4:

In the student list, locate the row for the student whose password you want to reset, and in
the Options column, click the key ( ) icon. The User and Password dialog box appears.

Step 5:

Change the password in the Password field, and then click Save to reset the student’s
password. A notification bar appears at the top of the window, indicating the change was
saved.

Resetting Benchmark Assessments
This section explains how to reset the Benchmark assessment for one or more students within a group.
Resetting the Benchmark allows students to take the assessment again.
To reset the Benchmark assessment, perform these steps.
Step 1:

Click the Groups Manager option in the Teacher Panel, and use the search feature to find the
groups associated with your teacher account.

For instructions about using the search feature, refer to the Using the Groups Manager >
Managing Groups > Finding a Group section.
Step 2:

In the search results table, locate the row for the group you want to examine, and in the
Options column, click the pencil ( ) icon. The General Information, Group Students,
Assessment Rubrics and Activities, and Customize Time tabs appear in the Groups Manager
page.

Step 3:

Click the Group Students tab, and select a course in the Show students enrolled in drop-down
menu to display the list of students enrolled in that class.
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Step 4:

In the Select All column, click the check box for each student for whom you want to reset the
Benchmark. (Alternatively, click the Select All check box in the table heading row to select all
students.)

Step 5:

Click the Reset Benchmark link. A message window appears asking you to confirm that you
want to proceed.

Step 6:

Click OK to reset the Benchmark for the selected students. A notification bar appears at the
top of the window, indicating the Benchmark has been successfully reset.

Assigning a Custom Activity
This section explains how to use the Assessment Rubrics and Activities tab in the Groups Manager to
assign a custom activity to a group, adjust the grading rubric, and set a due date.
To assign a custom activity to a group, perform these steps.
Step 1:

Click the Groups Manager option in the Teacher Panel, and use the search feature to find the
groups associated with your teacher account.

For instructions about using the search feature, refer to the Using the Groups Manager >
Managing Groups > Finding a Group section.
Step 2:

In the search results table, locate the row for the group to which you want to assign a custom
activity, and in the Options column, click the pencil ( ) icon. The General Information, Group
Students, Assessment Rubrics and Activities, and Customize Time tabs appear in the Groups
Manager page.

Step 3:

Click the Assessment Rubrics and Activities tab.
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Step 4:

In the Show settings of drop-down menu, select the course with which the custom activity is
associated.

Step 5:

Click the Assign Activity button to display the Assign Activity window. The custom activities
available for the specified course appear.
To display your school’s shared custom activities, click the All Custom Activities option in
the Author section.

Step 6:

Select a custom activity from the list, and then click Assign to add this activity to the list of
activities students should complete. A notification bar appears at the top of the window
indicating the activity has been assigned to the group. The Assessment Rubrics and Activities
table updates to include the activity.
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Step 7:

Enter the appropriate dates in the from and to fields in the Exam Availability column.

Step 8:

In the custom activity row, assign a percentage value in the Value column.

Step 9:

Adjust the percentage values for the remaining activities as needed so the sum of all values
equals 100%.
The values contained in the Value column must equal 100%.

Step 10: Click Save. A notification bar appears at the top of the window indicating the changes have

been saved.

Step 11: Repeat Steps 5-10 to assign additional activities to the group, as necessary. Change the

appropriate percentage values so that the total percentage value equals 100%.

When students access the course to which you assigned the new activities, the Tasks icon in the
navigation bar will reflect the number of activities currently assigned.

As you add or remove activities, this number automatically adjusts to reflect the assigned number of
activities. In the example shown in the preceding figure, if you delete an assigned activity, the number
will automatically change to 1.
Students can click the
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Removing the Assignment of a Custom Activity
This section explains how to use the Assessment Rubrics and Activities tab in the Groups Manager to
remove the assignment of a custom activity.
To remove the assignment of a custom activity from a group, perform these steps.
Step 1:

Click the Groups Manager option in the Teacher Panel, and use the search feature to find the
groups associated with your teacher account.

For instructions about using the search feature, refer to the Using the Groups Manager >
Managing Groups > Finding a Group section.
Step 2:

In the search results table, locate the row for the group from which you want to remove the
assignment of a custom activity, and in the Options column, click the pencil ( ) icon. The
General Information, Group Students, Assessment Rubrics and Activities, and Customize Time
tabs appear in the Groups Manager page.

Step 3:

Click the Assessment Rubrics and Activities tab and, in the Show settings of drop-down
menu, select the course with which the custom activity is associated.
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Step 4:

Locate the row containing the custom activity you want to delete, and then in the Options
column, click the delete (X) icon. A message window appears asking you to confirm that you
want to proceed. Click OK to confirm the deletion. The rubric table updates to reflect the
change.

Step 5:

Adjust the percentage values for the remaining activities as needed so the sum of the values
equals 100%.
The values contained in the Value column must equal 100%.

Step 6:

Click Save. A notification bar appears at the top of the window indicating the changes have
been saved.

Modifying Course Rubrics
This section explains how to use the Assessment Rubrics and Activities tab in the Groups Manager page
to modify the rubrics for a course. Changes made in this tab apply to all students in the course.
To customize the rubrics for an individual student, refer to the Using the Groups Manager > Viewing and
Editing Student Information section.
To modify the rubrics for a course, perform these steps.
Step 1:

Click the Groups Manager option in the Teacher Panel, and use the search feature to find the
groups associated with your teacher account.

For instructions about using the search feature, refer to the Using the Groups Manager >
Managing Groups > Finding a Group section.
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Step 2:

In the search results table, locate the row for the group for which you want to modify the
course rubrics, and in the Options column, click the pencil ( ) icon. The General Information,
Group Students, Assessment Rubrics and Activities, and Customize Time tabs appear in the
Groups Manager page.

Step 3:

Click the Assessment Rubrics and Activities tab, and select a course in the Show settings of
drop-down menu to access the rubrics and assigned activities for the course.

Step 4:

To alter the weighting for any of the listed elements, click in the Value field for that element
and enter the new value. The total value of all elements must add up to 100.0%.

Step 5:

Click Save. A notification bar appears at the top of the window indicating the changes were
saved.

Modifying Assessment Time Limits
This section explains how to use the Customize Time tab in the Groups Manager page to change the
amount of time allotted to complete the Benchmark and/or the Validate Exercise. Changes made in this
tab apply to all students in the course.
To customize the time limits for an individual student, refer to the Using the Groups Manager > Viewing
and Editing Student Information section.
To modify assessment time limits, perform these steps.
Step 1:

Click the Groups Manager option in the Teacher Panel, and use the search feature to find the
groups associated with your teacher account.
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For instructions about using the search feature, refer to the Using the Groups Manager >
Managing Groups > Finding a Group section.
Step 2:

In the search results table, locate the row for the group for which you want to change time
limits, and in the Options column, click the pencil ( ) icon. The General Information, Group
Students, Assessment Rubrics and Activities, and Customize Time tabs appear in the Groups
Manager page.

Step 3:

Click the Customize Time tab and select a course in the Show settings of drop-down menu to
view the current Benchmark and Validate Exercise time limits for the course.
The default time limit for each exercise is set to 00:50 (zero hours and 50 minutes) – the
amount of time allotted when you take a Microsoft Office Specialist certification exam.

Step 4:

In the Time to Complete column, click in the (hh:mm) field for the exercise(s) you want to
modify. Then enter the amount of time you want to allow. You may enter a value from 00:00
to 23:59 (inclusive).

Step 5:

Click Save. A notification bar appears at the top of the window indicating the changes were
saved.

Using Reports
You can use the Reports option in the Teacher Panel to track student progress and provide course
completion statistics for each course in Jasperactive.
You can work with reports in Default view or in Export view.
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Viewing Reports in Default View
This section explains how to work with reports in Default view. To work with reports in Default view,
perform these steps.
Step 1:

In the Teacher Panel, click the Reports option.
The Reports page appears and displays the Learning Report and Custom Activity Report
tabs.

Use the Learning Report tab to view reports that show student progress and scores on the
default (built-in) assessments, lesson quizzes, and lesson exercises.
Use the Custom Activity Report tab to view reports that show student progress and scores on
custom activities that you have assigned.
You can click the Go to Export view link to work with reports in Export view. For information
about working with reports in Export view, refer to the Using Reports > Viewing Reports in
Export View section.

Viewing Learning Reports in Default View
Learning reports show student progress and scores on the default assessments, lesson quizzes, and
lesson exercises in each Jasperactive course. You can view these reports from the Learning Report tab in
the Reports page.
To view Learning Reports, perform these steps.
Step 1:

In the Learning Report tab, select a course from the Application drop-down menu, then click
Show Report.
The window expands to list the groups (classes) for the selected application that are
associated with your teacher account.
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The summary information for each group includes the group name and key, the number of
students linked to the group, a description of the group, and the overall progress of the
group.
Step 2:

In the group list, click the Group link for the group you want to examine.
Jasperactive displays a table of student information.

Viewing Assessment Score Details for a Student
You can view the score details about the individual skills tested in each Jasperactive assessment by
clicking the score in the appropriate column in the student table. Assessment score details display in a
new window (or window tab, depending upon your browser settings).
To view the score details for an assessment for an individual student, perform these steps.
Step 1:

In the table of student information, locate the row for the student whose score details you
want to view, then click the appropriate score link in the Benchmark, Create, or Validate
column.
The assessment results display in a new window or window tab.
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Step 2:

Close the Exercise Results window (or window tab) to return to the Reports page.

Viewing Course Progress Details for a Student
You can view detailed data about a student's course progress by clicking the student's name in the
student table and drilling down through the available information. Each link that you click as you drill
down into the data expands the level of detail shown. You can click the link again to collapse the
progress details.
To view a student’s detailed course progress, perform these steps.
Step 1:

In the table of student information, locate the row for the student whose course progress
details you want to view, then click the student's name in the Name column.
The table expands to show the student's overall progress statistics by lesson.
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Step 2:

To view details about each exercise within a specific lesson, click the lesson name in the
Lesson column.
The table expands to show performance statistics for each lesson exercise.

Step 3:

To view details about each task within an exercise, click the exercise name in the Exercise
column.
The table expands to show which tasks were and were not performed correctly.
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Step 4:

To hide the report details for a student, click the student's name in the Name column.

Viewing Custom Activity Reports in Default View
If you have assigned custom exercises or quizzes to your students, you can work in the Custom Activity
Report tab to view a report about a student’s progress on the custom activities.
You can view detailed performance and score statistics for a custom activity by clicking the activity name
in the custom activities table and drilling down through the available information. Each link that you
click as you drill down into the data expands the level of detail displayed. You can click the link again to
collapse the report details.
To view a Custom Activity Report, perform these steps.
Step 1:

Step 2:

In the Reports page, click the Custom Activity Report tab.

options display.

The Custom Activity Report

Select a course from the Application drop-down menu, then click Show Report.
The window expands to list the groups (classes) for the selected application that are
associated with your teacher account, and within which, you have assigned custom activities.
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The summary information for each group includes the group name, the number of students
who have performed the assigned custom activities, a description of the group, and the
overall progress (percentage) of group participation in the custom activities.
Step 3:

In the group list, click the Group link for the group you want to examine.
Jasperactive displays a table of custom activities assigned to members of the group.

Step 4:

To view details about which students have attempted a custom activity, in the table of custom
activities, locate the row for the activity you want to see, then click the appropriate activity
name link in the Custom Exam column.
The table expands to show the overall progress of those students who have attempted the
activity.

Step 5:

To view the activity scoring details for a student, click the appropriate student name link.
The table expands to show which specific tasks/questions were or were not
performed/answered correctly.
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Step 6:

To hide the report details for a custom activity, click the activity name link in the Custom
Exam column.

Viewing Reports in Export View
This section explains how to work with reports in Export view. To work with reports in Export view,
perform these steps.
Step 1:

In the Teacher Panel, click the Reports option.
The Reports page appears and displays the Learning Report and Custom Activity Report
tabs, and a Go to Export view link. To work with reports in Export view, you must first switch
to Export view.

Step 2:

In the upper-right corner of the window, click the Go to Export view link to switch to Export
view. The window updates to show the options available in Export view.
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Use the Learning Report tab to view reports that show overall progress and assessment
scores for students in each of your groups.
Use the Custom Activity Report tab to view reports that show student progress and scores on
custom activities that you have assigned.
You can click the Go to default view link to work with reports in Default view. For information
about working with reports in Default view, refer to the Using Reports > Viewing Reports in
Default View section.

Generating Learning Reports in Export View
Learning reports show course progress percentages and assessment scores for students within a
Jasperactive group. You can generate these reports from the Learning Report tab in the Reports page.
To generate Learning Reports, perform these steps.
Step 1:

In the Learning Report tab, select a course from the Application drop-down menu.

Step 2:

Select the check box(es) for the group(s) for which you want to generate a report.

Step 3:

Click Show Report.
The window expands to display a Learning Report for the group. The report shows overall
progress and grade statistics for the group. Student information and scores appear in the
student table in the Learning Report, and a bar chart appears below the table.
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You can use the toolbar options that appear immediately below the Show Report button to
navigate the report, change the zoom setting, print the report, and export the report in
various formats. In the preceding figure, the available toolbar options are:

Not all toolbar options are available in all report types.

For each student listed in the student table, you can generate an Exercise Result report to
show assessment score details, or you can generate an individual Overall Progress report to
view student performance for each lesson in the course.
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Generating an Individual Exercise Result Report for an Assessment
An Exercise Result report will show score details for the individual skills tested in each Jasperactive
assessment. To generate an Exercise Result report for an assessment, click the score in the appropriate
column in the student table. The Exercise Result report displays in a new window (or window tab,
depending upon your browser settings).
To generate an Exercise Result report for an assessment for an individual student, perform these steps.
Step 1:

In the student table of the Learning Report, locate the row for the student whose score
details you want to see, then click the appropriate score link in the Benchmark Results, Create
Results, or Validate Results column.
The Exercise Result report for the assessment appears in a new window or window tab.

Step 2:

Print or export the Exercise Result report data using the toolbar options at the top of the
page.

Step 3:

Close the Exercise Result report window (or window tab) to return to the Learning Report.

Generating an Overall Progress Report for a Student
You can generate an Overall Progress report for a student by clicking the student's name in the student
table of the Learning Report. You can also drill down through the available information in the Overall
Progress report. Each link that you click as you drill down into the data generates a new report about the
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specific details and displays the report in a new window (or window tab). You can close the new window
or window tab to return to the Overall Progress report.
To generate an Overall Progress report for a student, perform these steps.
Step 1:

In the student table of the Learning Report, locate the row for the student whose course
progress details you want to view, then click the completion percentage link in the Overall
Progress column.
The Overall Progress report displays in a new window or window tab.

Step 2:

To view a graph of the student’s overall progress, click the Last Page navigation button in the
toolbar above the report.
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Step 3:

Print or export the Overall Progress report data using the toolbar options at the top of the
page.

You can click links in the overall progress report to generate reports about quiz scores for each lesson,
and to generate reports about scores for individual exercises within each lesson.

Generating an Exercise Result Report for Quiz Details
You can generate an Exercise Result report that displays detailed information about how a student
scored on each lesson quiz.
To generate an Exercise Result report containing detailed lesson quiz information, perform these steps.
Step 1:

In the Overall Progress report, click the score link for the appropriate lesson in the Quiz
Results column.
The Exercise Result report for the selected quiz displays in a new window or window tab.
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Step 2:

Print or export the Exercise Result report data using the toolbar options at the top of the
page.

Step 3:

Close the Exercise Result report window (or window tab) to return to the Overall Progress
report.

Generating an Exercise Result Report for Lesson Exercises
You can also generate an Exercise Result report that displays detailed information about how a student
scored in each lesson exercise.
To generate an Exercise Result report containing detailed lesson exercise information, perform these
steps.
Step 1:

In the Overall Progress report, click the score link for the appropriate exercise in the Result
column.
The Exercise Result report for the selected exercise displays in a new window or window
tab.
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Step 2:

Print or export the Exercise Result report data using the toolbar options at the top of the
page.

Step 3:

Close the Exercise Result report window (or window tab), and then close the Overall Progress
report window (or window tab) to return to the Learning Report page.

Viewing Custom Activity Reports in Export View
If you have assigned custom exercises or quizzes to your students, you can work in the Custom Activity
Report tab to generate a report of your students' progress on the custom activities.
To generate a Custom Activity Report, perform these steps.
Step 1:

Step 2:
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options display.

Select a course from the Application drop-down menu.
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Step 3:

Select the desired custom activity from the Activity drop-down menu.

Step 4:

Select the check box(es) for the group(s) for which you want to generate a report.

Step 5:

Click Show Report.
The window expands to display a Custom Activity Report for the selected group(s). The report
shows overall scoring for the group(s).

Student information and scores appear in the student table in the report, and a bar chart
appears below the table.
Step 6:

Print or export the Custom Activity Report using the toolbar options at the top of the page.

Step 7:

Click the Home Page (

) icon in the navigation bar to return to the Teacher Panel.
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Downloading the Teacher Resources
The Teacher Panel includes an option for downloading the teacher resources developed for each
Jasperactive course. You can use these resources to prepare for your class.
To download the Teacher Resources, perform these steps.
Step 1:

In the Teacher Panel, click the Download Teacher Resources option. The Download Teacher
Resources page appears.

If this is your first time accessing this option, the Licensing Agreement will appear. Read

the end user license agreement carefully, click the I ACCEPT the license agreement radio
button, and then click Continue to access the Download Teacher Resources page.
Step 2:

Select a Jasperactive course from the Select a Course drop-down menu.
The teacher resources for the selected course appear in a table.
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Step 3:

Click an individual resource to open/download, or click Download All to download a ZIP file
that contains all the resources.

Using the Jasperactive Installer
As a teacher, you need not install the Jasperactive application on your local system. You can log in to
Jasperactive online to perform all teacher functions. However, you do need to install Jasperactive if you
want to take a Jasperactive course as a student.
The current version of the Jasperactive application must be installed on your system before you can take
any Jasperactive courses.
This section explains how to use the Jasperactive Installer.
When you log in to your account, the J-icon in the navigation bar on your personal Jasperactive home
page displays the current status of the software by displaying one of the three icons described in the
following table.
Icon

Indicates
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The application is not installed. Click the icon to open the Jasperactive Installer window.
The application is installed but is not the latest version. Click the icon to update.
The application is installed and is up-to-date.
You can click the J-icon in the navigation bar, or you can click the Installer option in the Teacher
Panel to install Jasperactive.
To install Jasperactive, perform these steps.

Step 1:

In the Teacher Panel, click the Installer option (or click the J-icon in the navigation bar). The
Jasperactive Installer page appears.

Step 2:

In the Complete Version column, click the Download link to begin the download process.

Step 3:

Because the steps to install Jasperactive differ slightly depending on the browser you are
using, this step shows you how to install Jasperactive in three browsers: Chrome, Mozilla
Firefox, and Internet Explorer.
•

If you are using the Chrome browser, the downloaded file will appear as a button in the
status bar.

The projected time for completing the download will appear on the button. After the file
has finished downloading, only the file name displays on the button. Click the button and
proceed to Step 4.
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•

If you are using the Mozilla Firefox browser, a dialog box appears.

Click the Save File button in the dialog box and watch the progress indicator in the
upper-right portion of the browser window.

When the progress indicator changes to a down-facing arrow ( ), click the arrow to
display a menu of downloaded items, then click the Jasperactive.msi item in the menu
and proceed to Step 4.

•

If you are using the Internet Explorer browser, a notification bar appears at the bottom
of the browser window.

In the notification bar, click Save. When the file has been downloaded, the options in the
notification bar update.

In the notification bar, click Run and proceed to Step 4.
Step 4:

A Windows Installer dialog box may display briefly and then the first screen of the
InstallShield Wizard appears.
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Step 5:

Click Next to move to the second wizard screen, in which you specify an installation location.

Step 6:

Click Next to accept the suggested installation location and display the third wizard screen, in
which you can view or change the installation settings.
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Step 7:

Click Install to install the program.

Step 8:

Click Yes in the User Account Control prompt to proceed with the installation.

The wizard displays the progress of the installation. It may take several minutes to
complete the process.

© 2018 Jasper Learning Inc. – All rights reserved.

77

Jasperactive Teacher’s Guide
v1.0

When the installation is complete, the final wizard screen appears.

Step 9:

Click Finish.
The wizard closes and your personal Jasperactive home page displays.

If, after installing Jasperactive, your screen does not reflect the installation, log out of
Jasperactive and then log in again.

The Install Jasperactive Alert
Jasperactive will display an Install Jasperactive alert the first time a student tries to access one of his or
her activated courses – regardless of whether Jasperactive has been installed. This is also true when a
teacher changes to a student role and tries to access an activated course while working as a student.

Instruct students to proceed as outlined here:
Step 1:

If Jasperactive has not been installed yet, click Agree and download now and follow the
instructions to download and install the software.
If Jasperactive has already been installed, click Jasperactive is already installed on my
computer.
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